On Tue, 2005-04-12 at 15:10 -0400, Mark E. Mallett wrote:
I'm happy with the vacation statement syntax, and the description is
reasonable, but I also fear that it describes the implementation more
than the intent. Here's some alternate stub wording (not really fleshed
out) that might illustrate an alternate approach:
Vacation responses are not just per-address, but are per
vacation profile, which might be thought of as a representation
I war trying to do a rewrite myself, but couldn't get it to flow well.
this sounds good to me.
A vacation profile is created in one of two ways. The first way
is via an explicit handle, which names the profile. All
vacation statements that use the same handle will be considered
to have the same profile.
you are introducing the term "profile" here, but the keyword is :handle.
I think this mismatch is unfortunate and unnecessary. :profile is a
better name for the tag.
My dictionary disagrees. A profile is a view of something. A handle, OTOH, is a
way to refer to something. The word "profile" is IMO entirely inappropriate as
either a keyword or as a description of what's going on here.
The second way is via a synthesis of
the other vacation arguments ":days", ":subject", and ":from"
okay, so you went back to using all arguments in the hash? or is the
"etc." a reference to some other text.
I'd prefer the text was something like
The second way is via a synthesis of the other vacation
arguments which modify the response message, such as ":subject"
or the reason text.
"such as" is non-commital enough that we can leave the more stringent
explanation for a later paragraph.
incidentally, I don't think it's correct to include :days in the hash.
if you shorten the interval, there is no need to reset the database.
Right, :days clearly does not belong.
In any case, while the addition of some clarifying text is fine, I really don't
like the terminology changes that were made here. I'll see if I can come up
with an alternative that incorporates the descriptive text without changing the