But since you're the second person to mention that, I guess some
wordsmithing is in order to make that clear.
In that case, suggest changing the OPTIONAL to something like "RECOMMENDED
if the message has been held."
Other nits: if this is really about deliberate delays, I'd suggest
using a term like "queued" or "delay" or "hold" rather than "state".
I can think of states that might be interesting but don't involve a
delay, e.g. characterized as spam, or downcoded from 8 bits to 6 bits.
Also, it might be a good idea to have a state name for no delay, e.g
"queued none", both for the benefit of dorky software that always wants
to put the same set of clauses in its Received: headers, and to provide
an explicit way to say hey, this delay wasn't my idea.