maybe call the mts values: smtp, bsmtp (alias sendmail, for backwards compat),
I'm fine with merging spost into post. A couple of comments:
- I'm not so sure about about what to call it either. It gets kinda confusing
now that we have two different ways to call sendmail. I like "pipe" for
the spost replacement, but I think having "sendmail" would be confusing.
But I don't like "bsmtp" either (I assume that's "batched SMTP"? What's
particularly batched about it?). But I don't have any better suggestions.
Maybe "sendmail/smtp" and "sendmail/pipe"? With just "sendmail" meaning
"sendmail/smtp"? To me that's a little clearer.
- It occurs to me that some of these things should be overrideable via
mh_profile (like the path to sendmail). Just saying :-)
- It should be made clear in the man pages that in the "pipe" or
"sendmail/pipe" case that it's impossible to set the envelope-from
- Are we going to have some notification at runtime for those people who
put "spost" in their postproc a couple of decades ago for some
long-forgotten reason? :-) As far as I can tell that's pretty much the
case for everyone except Alex.
I was going to say that we should make sure that we create a test for it,
but I know David is the test suite champ :-)
Nmh-workers mailing list