[bugs #9050] Regex abort error in under Win32

2004-12-01 17:33:41
This mail is an automated notification from the bugs tracker
 of the project: MHonArc.

[bugs #9050] Latest Modifications:

Changes by: 
                Earl Hood <earl(_at_)earlhood(_dot_)com>
                Thu 12/02/2004 at 00:37 (US/Central)

            What     | Removed                   | Added
   Component Version | 5.8.3                     | 2.6.10

[bugs #9050] Full Item Snapshot:

URL: <>
Project: MHonArc
Submitted by: 0
On: Fri 05/21/2004 at 18:59

Category:  MIME Filter
Severity:  5 - Average
Item Group:  Incorrect Behavior
Resolution:  Fixed
Privacy:  Public
Assigned to:  None
Status:  Open
Platform Version:  Win32
Perl Version:  5.8.3
Component Version:  2.6.10
Fixed Release:  CVS

Summary:  Regex abort error in under Win32

Original Submission:  I use a text-based mail reader, but run MHonArc -single 
on individual mail messages that require a more robust HTML display.  This had 
been working very well with MHonArc 5.6.8, but when I recently upgraded to 
5.6.10, I started seeing this error for many of the messages I tried to display:

Trailing  in regex m// at C:Perlsitelib/ line 366, <GEN0> line 40.

I've attached the Perl script I use to pass the message to MHonArc and to start 
a browser window.



Follow-up Comments

Date: Wed 08/18/2004 at 18:18       By: Earl Hood <ehood>
The CVS repository on Savannah is not currently being used
due to funtional limitations imposed after the security
breach months ago.

Snapshot distributions are available at

Date: Tue 06/29/2004 at 09:07       By: 0 <None>
The patch is also archived here:

Date: Tue 06/29/2004 at 07:01       By: 0 <None>
I've encountered the same error converting mboxes with various attachments.  
I'd appreciate the patch but I only see up to 1.19 in the CVS :(

Date: Tue 06/22/2004 at 17:23       By: 0 <None>
I check the cvs repository and the version with the change does not appear 

Date: Sat 05/22/2004 at 16:50       By: Earl Hood <ehood>

Looks like problem is only for Windows systems.  I committed
changed to into CVS that should fix this

Date: Fri 05/21/2004 at 19:04       By: 0 <None>
Here's an example mail message that exhibits the problem.  This fails from the 
command line also.


File Attachments

Date: Fri 05/21/2004 at 19:04  Name: 18660  Size: 36.62KB   By: None
Sample message which fails with MHonArc 5.6.10;item_file_id=1332

Date: Fri 05/21/2004 at 18:59  Name:  Size: 904B   By: None
Perl script to run selected message through MHonArc;item_file_id=1331

For detailed info, follow this link:

  Message sent via/by Savannah

To sign-off this list, send email to majordomo(_at_)mhonarc(_dot_)org with the

<Prev in Thread] Current Thread [Next in Thread>
  • [bugs #9050] Regex abort error in under Win32, Earl Hood <=