Re: higher memory requirements in 2.4.0 ? [isolated]

1999-06-29 02:19:23
On June 29, 1999 at 01:40, Jeff Breidenbach wrote:

Note, my system configuration is different from yours.  I am running
Perl 5.005_03 on RH 5.2 w/2.2.9 kernel.  There is a possibility that
Perl 5.004 has some memory leaks exposed by MHonArc v2.4.0.

The perl version that is recommended in RedHat 5.2's errata notes is:

# rpm -q perl MHonArc

RH 5.2 is somewhat old.  I've made it a habit of just building from
source obtained from

Running under this perl, all memory is consumed every time I try
asking MHonArc 2.4.0 to add to the big database. So, I tried upgrading
perl. Scrounging the net for a slightly newer version of perl, I found
this one in

# rpm -q perl

# perl -v

This is perl, version 5.005_02 built for i386-linux-thread 
Threading is currently very experimental in Perl.  

MHonArc 2.4.0 worked fine under this perl and contained itself to
about 143 meg. (More or less, I get the number from watching top
during the run.)  Switching back to the old version of perl caused the
problem to reappear.  I'm not going to draw any broad sweeping
conclusions from this experiment, but it's safe to say I will be
sticking with the newer version of perl.

Hey, if it works, go with it.


<Prev in Thread] Current Thread [Next in Thread>