Re: @INC problem

2002-03-08 13:29:54
On March 8, 2002 at 10:18, Andrew Lieu wrote:

Can't locate in @INC (@INC contains: lib
/usr/local/lib/perl5/5.6.0/IP28-irix /usr/local/lib/perl5/5.6.0
/usr/local/lib/perl5/site_perl .) at /usr/local/bin/mhonarc line 39.

However, if I ran as root, things went fine.
I did found in /usr/local/lib/perl5/site_perl/5.6.0.
I ran the two commands in root and non-root accounts: which perl and
which mhonarc
they both respectively give the same answers.  I have the same perl
execuatables in /usr/bin/    and /usr/local/bin.
What troubles me is how come root can run mhonarc but non-root can't.
Thanks for your help.

What are the permission for the file
/usr/local/lib/perl5/site_perl/5.6.0/  Check the
permissions under the non-root account and see if you can view the
file under the non-root account.

The perl executed is the one specified in the first line of the
'/usr/local/bin/mhonarc' program, i.e. the #! line.


<Prev in Thread] Current Thread [Next in Thread>