xsl-list
[Top] [All Lists]

Re: [xsl] difference between an integer and current-dateTime()

2020-03-28 06:42:29
Am 28.03.2020 um 01:23 schrieb Mukul Gandhi 
gandhi(_dot_)mukul(_at_)gmail(_dot_)com:

I've tried following XSLT stylesheet upto now, based on your suggestions,

<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform";
                          xmlns:xs="http://www.w3.org/2001/XMLSchema";
                          exclude-result-prefixes="xs"
                          version="3.0">

     <xsl:output method="text"/>

     <xsl:param name="secsSinceEpoch" as="xs:integer"/>

     <xsl:template match="/">
        <xsl:variable name="epochDateTime"
select="xs:dateTime('1970-01-01T00:00:00Z') +

          xs:dayTimeDuration('PT' || $secsSinceEpoch || 'S')"

          as="xs:dateTime"/>
        <xsl:variable name="diffDTduration" select="current-dateTime() -
$epochDateTime" as="xs:dayTimeDuration"/>
        <xs:value-of select="$diffDTduration"/>
     </xsl:template>

</xsl:stylesheet>

When I invoke above stylesheet, as follows (using Saxon 10),

java -classpath saxon-he-10.0.jar net.sf.saxon.Transform -s:trf1.xsl
-xsl:trf1.xsl secsSinceEpoch=1585039138

I get nothing into the output (i.e, <xs:value-of
select="$diffDTduration"/> doesn't print anything). Any thoughts, how
can I proceed further?

But there looks to be a valid value within the variable,  'epochDateTime'.

When I posted my suggestions I had only tried them with XPath/XQuery e.g.

let $epochDateTime := xs:dateTime('1970-01-01T00:00:00Z') +
xs:dayTimeDuration('PT' || 1585039138 || 'S')
return
current-dateTime() - $epochDateTime

in oXygen's XPath/XQuery builder window.

I am currently not sure why your code using those expressions in XSLT
doesn't output anything, I will try to investigate and let you know.


--~----------------------------------------------------------------
XSL-List info and archive: http://www.mulberrytech.com/xsl/xsl-list
EasyUnsubscribe: http://lists.mulberrytech.com/unsub/xsl-list/1167547
or by email: xsl-list-unsub(_at_)lists(_dot_)mulberrytech(_dot_)com
--~--

<Prev in Thread] Current Thread [Next in Thread>