In the Internet Mail Architecture draft:
There terms "Bounce Handler" and "Bounce address" are used. As the document
notes, the terms are not the nicest, but they seem to be the most prevalent.
(Earlier drafts attempted to use the term "Notices" but this gained to
There has been some community input suggesting that "Return [Path] address"
and "Return Handler" would be better choices.
Again, please note that the document attempts to use whatever is already
dominant in the community.
This is not an exercise in what any of us would prefer, but what we think
already has the most traction in the community (or is most likely to gain that
I'm soliciting comments.