[Top] [All Lists]

Re: email-arch: bounce vs... return?

2007-10-14 23:17:10

Dave Crocker wrote:
There terms "Bounce Handler" and "Bounce address" are used.

In 2.1.3 you say "bounce handling address".  That's a neologism
for a concept that already has more than enough names.  Why not
simply use "envelope sender address" as in the DSN RFCs ?

-| This Bounce handling address (also known as a Return address)
+| This envelope sender address (also known as Return address)

You could also replace the term "bounce handler" by "envelope 
sender" for consistency with SMTP and DNS terminology. 

This is not an exercise in what any of us would prefer, but what
we think already has the most traction in the community (or is
most likely to gain that traction.)

"MAIL FROM" (address) is also in use, but it's clumsy.
"2821-From" (address) certainly isn't better.
"Return" (address or path) is rather conservative, however
 readers might at least know the corresponding header field.
"Reverse path" is too technical, "bounce" (address) is too sloppy.

"Envelope sender" (address) is IMO the best choice.  You could
keep the term "bounce" in figure 3, because it expresses what
happens if an alleged "envelope sender" is NOT the "originator".