Re: Cryptic MHonArc error (revised posting)

1996-10-25 05:33:18
[Sorry for the delay but I really busy. Therefore the answer is also a
 bit terse and are not tested. But I saw no better reply up to know :-)]

Bill Silvert said:
Sorry, I forgot to put > before From and that messed up the header.
Here is a revised version of my prvious two postings, that seem to have
appeared as three:

That's a problem with the final mail delivery tool (/usr/bin/mail?) and
your MTA (sendmail?).  The final mail delivery tool should take care
to escape lines starting with 'From '.   Here it works does and I had
no problems with your mail.

I just tried running ver. 1.2.3 on a fairly small mail spool file and

Side note: Always a good idea to specify the version  perl,
and the operating system.

got the following error message:

Requiring MIME filter libraries ...
Converting messages to .
Reading /export/home/silvert/spool/czm .....Day out of range 1..31 in timelo

Yeah, the error messages of are not the best. This slightly
emproves it (cut&pasted so tabs may be converted to space):

--- /home/ach/perl/lib/     Wed Jan 24 00:07:04 1996
+++ ./      Thu Jan 25 22:40:04 1996
@@ -69,15 +69,15 @@
 sub cheat {
     $year = $_[5];
     $month = $_[4];
-    die "Month out of range 0..11 in\n" 
+    die "Month out of range 0..11: '$month' in\n" 
        if $month > 11 || $month < 0;
-    die "Day out of range 1..31 in\n" 
+    die "Day out of range 1..31: '$_[3]' in\n" 
        if $_[3] > 31 || $_[3] < 1;
-    die "Hour out of range 0..23 in\n"
+    die "Hour out of range 0..23: '$_[2]' in\n"
        if $_[2] > 23 || $_[2] < 0;
-    die "Minute out of range 0..59 in\n"
+    die "Minute out of range 0..59 : '$_[1]' in\n"
        if $_[1] > 59 || $_[1] < 0;
-    die "Second out of range 0..59 in\n"
+    die "Second out of range 0..59: '$_[0]' in\n"
        if $_[0] > 59 || $_[0] < 0;
     $guess = $^T;
     @g = gmtime($guess);

see also the thread:

I've looked at the file and all of the dates look legit. Since there is
nothing in the error message to indicate where the problem occured, I'm
stumped. Any ideas?

The missing ',' before 'Mon' is the problem.  To get the message date
mhonarc used the first 'Received:' field.(Order changed in 2.0.alpha)
 What confuses me is the fact that
this should be always the same because it's you MTA that adds it. So it
should always fail or never.  Contact you local Postmaster.

MHonArc runs fine on lots of other spool files, I maintain about a dozen
archives this way.


Later I wrote:

I found the message that caused the MHonArc hang (at least deleting it
solved the problem), and the header was (without the >'s):

From owner-czm  Tue May 21 20:19:38 1996
Received: by (931110.SGI/9From owner-czm  Mon Jun  3 16:20
Received: by (931110.SGI/931108.SGI.ANONFTP)
         id AA10795; Mon, 3 Jun 96 16:20:52 GMT
Date: Fri, 31 May 1996 08:32:23 -24000

The Date: field is added by the sender mail tool. If not the MTA
of the sender should add it.  Tell the sender of the mail that
they are a problem.   Mhmm... sender is also at
therefore contact your postmaster.

The last line is weird, but changing it to something like 

Date: Fri, 31 May 1996 08:32:23 -0500

didn't solve the problem. In any case, the error message

Mhonarc 1.* used the first Received: field before it tries the
Date: field.  This has changed in the alpha or mhonarc v2.0

"Reading /export/home/silvert/spool/czm .....Day out of range 1..31 in timel"

didn't give me much to go on in spotting the problem.

I finally removed the first "Received:" line and that did it. Was it the
extra space in front of the 3 in "June   3", or the lack of a newline?
In any case, it wasn't very friendly about it!

No. The problem are the missing ';'. Mhonarc splits the Received: using
';' as the seperator and tried to find a field on each of these fields.

See the second Received: header is has a ';' before Monday.

What is astonishing is that the first Received header seam to be a 
combination of a partialy writen Received: field and a the  mbox
seperator "From " line.  Could it be that you have a locking problem
and that two processes scrambled you mbox?   This would explain
why you normaly have no problems with mhonarc and you mboxes.

Hope it's helpful,
Bill Silvert, Habitat Ecology Section, Bedford Institute of Oceanography,
P. O. Box 1006, Dartmouth, Nova Scotia, CANADA B2Y 4A2, Tel. (902)426-1577

<Prev in Thread] Current Thread [Next in Thread>