Cryptic MHonArc error (revised posting)

1996-10-23 13:01:07
Sorry, I forgot to put > before From and that messed up the header.
Here is a revised version of my prvious two postings, that seem to have
appeared as three:

I just tried running ver. 1.2.3 on a fairly small mail spool file and
got the following error message:

Requiring MIME filter libraries ...
Converting messages to .
Reading /export/home/silvert/spool/czm .....Day out of range 1..31 in

I've looked at the file and all of the dates look legit. Since there is
nothing in the error message to indicate where the problem occured, I'm
stumped. Any ideas?

MHonArc runs fine on lots of other spool files, I maintain about a dozen
archives this way.


Later I wrote:

I found the message that caused the MHonArc hang (at least deleting it
solved the problem), and the header was (without the >'s):

From owner-czm  Tue May 21 20:19:38 1996
Received: by (931110.SGI/9From owner-czm  Mon Jun  3 16:20:52 
Received: by (931110.SGI/931108.SGI.ANONFTP)
         id AA10795; Mon, 3 Jun 96 16:20:52 GMT
Message-Id: <9606031620(_dot_)AA10786(_at_)biome(_dot_)bio(_dot_)dfo(_dot_)ca>
Date: Fri, 31 May 1996 08:32:23 -24000

The last line is weird, but changing it to something like 

Date: Fri, 31 May 1996 08:32:23 -0500

didn't solve the problem. In any case, the error message

"Reading /export/home/silvert/spool/czm .....Day out of range 1..31 in"

didn't give me much to go on in spotting the problem.

I finally removed the first "Received:" line and that did it. Was it the
extra space in front of the 3 in "June   3", or the lack of a newline?
In any case, it wasn't very friendly about it!

Bill Silvert, Habitat Ecology Section, Bedford Institute of Oceanography,
P. O. Box 1006, Dartmouth, Nova Scotia, CANADA B2Y 4A2, Tel. (902)426-1577

<Prev in Thread] Current Thread [Next in Thread>