Error: << Undefined subroutine "main'expired_time" >>

1997-04-21 11:38:47
When using MHonArc (v2.0.0 beta 3), downloaded and installed without making
modifications to the code, I get the message: 

Undefined subroutine "main'expired_time" called at
/usr/groups/nic/bin/MHonArc2/mhonarc line 1234, <FILE> line 34.

This is with that mhonarc executable using Perl 4.0.  I confess to not
knowing much about Perl (yet, hopefully ;-), but I "heard" that there are
some significant differences between 4 and 5, so I tried this: I changed
the executable to use Perl 5.003, and got instead the similar error: 

Undefined subroutine &main::expired_time called at
/usr/groups/nic/bin/MHonArc2/mhonarc line 1234, <FILE> chunk 34

This appears to refer to this piece of code in the executable:

    ## Return if message to old to add ##
    if (&expired_time($index)) {
        return ("", "", "", "", "");

That subroutine is defined in, and I noticed that when I run the
mhonarc executable, that file does NOT show up among those in the list of
files shown after "Requiring ...."

Is this a known bug in MHonArc, or ... ?  TIA for any tips,

 Stefan Kramer    \|/    skramer(_at_)cac(_dot_)washington(_dot_)edu

P.S.: This is running on: ULTRIX 4.2 0 RISC

<Prev in Thread] Current Thread [Next in Thread>