Segmentation fault

1997-08-06 14:02:48
MhonArc enthusiasts,

I am running Mhonarc on a solaris 2.4 system using perl 5.004.  I'm 
wondering if the occurance of the dump may be due to something other than 
permissions to writing to the directory.  

MhonArc was automatically archiving mail until it hit msg00009.html.  I 
checked it manually form the command line:

        %mhonarc -add -outdir /usr2/www/deposit/ /var/mail/dep

Reading database ...
Requiring content filter libraries ...
Requiring charset filter libraries ...
Adding messages to /usr2/www/deposit/
Reading /var/mail/dep ...............
Writing mail ...........Segmentation fault (core dumped)

Since it looks like Writing mail... is the part it is having trouble doing,
I checked the permissions.  This account is added to the correct group 
to write to this directory and can write new files within the directory.

NOTE: I first received this type of message when I first installed 
MhonArc and was able to correct it by upgrading from perl 5.001 to 5.004.
Also all other accounts on this machine work great.

I removed the .mhonarc.lck directory created in /usr2/www/deposit/ and 
the core file created in the home directory and tried again--> same result.

Any suggestions would be greatly appreciated.

Thank you,
Matt Maher

BTW  Great program!

<Prev in Thread] Current Thread [Next in Thread>