getting glimpseindex to work with wilma

1998-10-23 09:22:03
I have been using MHonArc v2.2.0 for a couple of months to archive a
few mailing lists and I have been very impressed with the ease with
which it produces the web pages. I want to add a search function and
have been trying to set up wilma-1.4, but I have been having problems
with glimpseindex. Wilma is constructing the pages OK, but
glimpseindex is choking on something. I get error messages and when I
search no results are returned. 

Glimpseindex is not totally broken, because when I run it from the
command line to make a tiny index, I have no problem.

$ wilma_reindex test
Re-incing test.9808
/user3/grr/bin/mhonarc -add -rcfile /user3/grr/wwwhome/mycgi/.wilma/test.rc 
-outdir 9808 test.9808
Reading database ...
Reading resource file: /user3/grr/wwwhome/mycgi/.wilma/test.rc ...
Adding messages to 9808
Reading test.9808 ..........
Writing mail ..........
Writing 9808/index.html ...
Writing 9808/threads.html ...
Writing database ...
10 messages
/usr/local/bin/glimpseindex -f -o -H index -M 50 -z 9808
Using 485451 words as threshold before merge

This is glimpseindex version 3.0, 1995.

Indexing "/user3/grr/wwwhome/test/9808" ...

Size of files being indexed = 15854 B, Total #of files = 13
sort: °æ°í: ÀÔ·Â ÆÄÀÏ /user3/grr/wwwhome/test/index/.glimpse_index.tmpÀÇ 
³¡¿¡ Ãß°¡µÇ´Â NEWLINEÀÌ ºüÁü
sort: °æ°í: ÀÔ·Â ÆÄÀÏ /user3/grr/wwwhome/test/index/.glimpse_index.tmpÀÇ 
³¡¿¡ Ãß°¡µÇ´Â NEWLINEÀÌ ºüÁü

[This is a UNIX error message that has been translated into Korean by my
ISP. It says: sort: Warning: NEWLINE added to the end of input file
.glimpse_index.tmp has been deleted.]

Index-directory: "/user3/grr/wwwhome/test/index"
Glimpse-files created here:
-rw-r--r--   1 grr      jjja          556 Oct 23 21:51 .glimpse_filenames
-rw-r--r--   1 grr      jjja           52 Oct 23 21:51 .glimpse_filenames_index
-rw-------   1 grr      jjja           34 Oct 23 21:51 .glimpse_index
-rw-r--r--   1 grr      jjja          116 Oct 23 21:51 .glimpse_messages
-rw-r--r--   1 grr      jjja          942 Oct 23 21:51 .glimpse_partitions
-rw-r--r--   1 grr      jjja         1846 Oct 23 21:51 .glimpse_statistics
-rw-r--r--   1 grr      jjja       262144 Oct 23 21:51 .glimpse_turbo

Then, when I search with glimpse, no results are returned.

I installed glimpse and glimpseindex 3.0 myself in my own bin
directory, but I still get the same problem. The ISP is running:

SunOS bora 5.5.1 Generic_103640-21 sun4d sparc SUNW,SPARCcenter-2000

and ulimit -a returns:

time(seconds)        unlimited
file(blocks)         unlimited
data(kbytes)         2097148
stack(kbytes)        8192
coredump(blocks)     unlimited
nofiles(descriptors) 64
vmemory(kbytes)      unlimited

Can anyone suggest what I should be doing?

::::greg matheson teacher(_at_)asan(_dot_)sch(_dot_)ac(_dot_)kr

<Prev in Thread] Current Thread [Next in Thread>
  • getting glimpseindex to work with wilma, teacher(_at_)asan(_dot_)sch(_dot_)ac(_dot_)kr <=