MHonArc bug (v2.3.3)

1999-01-22 13:42:55
Version of Perl (can be retrievied by "perl -v"). 

This is perl, version 5.004

Version of the program (can be retrievied by "mhonarc -v"). 

MHonArc v2.3.3 (Perl 5.004)

The operating system you are using 

HP-UX hpcvcdv B.10.20 A 9000/780 2010073319 two-user license

The exact command-line used to invoke the program. 

/home/bruceh/net/mhonarc/MHonArc2.3.3/install/mhonarc \
-rcfile /usr/warts/totem/lib/majordomo/rcfile \
-outdir avo_expert \
-nolock \

Error/diagnostic messages from the program. 

Reading resource file: /usr/warts/totem/lib/majordomo/rcfile ...
Converting messages to avo_expert
Reading /usr/warts/totem/lib/majordomo/archive/avo_expert ....................
Writing mail .Attempt to free unreferenced scalar at /home/bruceh/net/mhonarc/MH
onArc2.3.3/install/ line 148.

Any other information that might prove useful (eg. input files, 
resource files, environment settings, etc). 

Running mhonarc from a ksh script (mk_test) from cron. Permissions are 
(note setuid and setguid):

        -rwsr-Sr-x   1 bruceh     totem          367 Jan 21 15:04 mk_test

Error occurs when I run as:

        uid=567(bruceh) gid=90(niddesctr)

No errors when I run as gid=98(totem)

Thanks for any help you can provide.


 | Bruce Hauge                                                      |
bruceh(_at_)cv(_dot_)hp(_dot_)com |
 | Integrated Circuits Business Division    PHONE: (541) 715-2675   |
 | 1000 NE Circle Blvd., MS: 133A           FAX: (541) 715-2145     |
 | Corvallis, OR  97330                                             |

<Prev in Thread] Current Thread [Next in Thread>