Re: MHonArc bug (v2.3.3)

1999-01-29 15:25:26
---Bruce Hauge <bruceh(_at_)hpcvcdv(_dot_)cv(_dot_)hp(_dot_)com> wrote:

This is perl, version 5.004
MHonArc v2.3.3 (Perl 5.004)
HP-UX hpcvcdv B.10.20 A 9000/780 2010073319 two-user license

The exact command-line used to invoke the program. 

/home/bruceh/net/mhonarc/MHonArc2.3.3/install/mhonarc \
-rcfile /usr/warts/totem/lib/majordomo/rcfile \
-outdir avo_expert \
-nolock \
Reading resource file: /usr/warts/totem/lib/majordomo/rcfile ...
Converting messages to avo_expert
Reading /usr/warts/totem/lib/majordomo/archive/avo_expert
Writing mail .Attempt to free unreferenced scalar at
onArc2.3.3/install/ line 148.
Running mhonarc from a ksh script (mk_test) from cron. Permissions
(note setuid and setguid):

      -rwsr-Sr-x   1 bruceh     totem          367 Jan 21 15:04 mk_test

Error occurs when I run as:

      uid=567(bruceh) gid=90(niddesctr)

No errors when I run as gid=98(totem)

This looks like a problem with the port of perl on your system.  The
error message comes from perl and not from mhonarc.

Since I do not have access to a HP-UX 10.20 system, I have no
way to figure out what is causes the error in perl.  Could be
related to taint mode if using setuid/getuid?  Have you tried
the latest version of perl to see if the problem still exists?


Earl Hood

Get your free address at

<Prev in Thread] Current Thread [Next in Thread>