Re: Can't locate auto/Digest/MD5/

2000-02-24 16:19:09
Just to close on this...

I ran Nat's test below and it passed.

I then installed 2.4.5 in a new area, and the error is gone.  I had
upgraded Perl from 5.003 to 5.005 since installing 2.4.4 originally, and
the new version was installed in the same place, so I don't know how it
would have affected the ability to find this particular Perl module. 
When I installed MH 2.4.4, I had put all the library files in
/usr/local/lib/perl5/site_perl.  This time I put them in

Anyway, it's working OK now.

For those, interested, here is the EXACT error message that was reported
by MHonArc 2.4.4:

Can't locate auto/Digest/MD5/ in @INC (@INC contains: lib
/usr/local/lib/perl5/site_perl/5.005 .) 
at /usr/local/lib/perl5/site_perl/ line 749

- Jim

Nathaniel Irons wrote:

On 2/24/2000 at 9:42 AM, Jim_Reisert(_at_)mint-tech(_dot_)com (Jim Reisert) 

The module I tried to build and install was Digest-MD5-2.09 that I
found on CPAN.

I did not find an md5_hex anywhere in that kit.

Run this line from the shell:

perl -e "use Digest::MD5 qw(md5_hex); print md5_hex(\"you've saved me 
network!\") . \"\n\";"

If it returns anything other than this MD5 hash:


then you have improperly installed the Digest::MD5 module, or "perl" is
aliased to an undesirable copy of the interpreter on your system.
Troubleshooting on that level is best attempted on-site.


Jim Reisert                        Voice:    781-685-3928
Mint Technology                    Fax:      781-685-3801
77 South Bedford Street            Email:    
Burlington, MA  01803              WWW:

<Prev in Thread] Current Thread [Next in Thread>