RE: Large archive conversion problem

2004-03-08 17:55:34

After your hint I tried looking into code more closely for close

In and after changing close (DIR) to closedir
(DIR ) it worked.

Now I am able to convert large archives with out any problem.

Thanks for all your help.


-----Original Message-----
From: Earl Hood [mailto:earl(_at_)earlhood(_dot_)com]
Sent: Monday, March 08, 2004 12:56 PM
To: mhonarc-users(_at_)mhonarc(_dot_)org
Subject: Re: Large archive conversion problem

On March 6, 2004 at 05:21, "Rangesh Kona" wrote:

  MHonArc v2.6.8 (Perl 5.00503 solaris)
A little old.

After examining the truss output, it appears that the problem
is either with perl or Solaris.  For some reason, each time an
attachment file is created, an open is done on the directory,
and there is nothing in the MHonArc source that is doing the
directory open.  Since the open64() calls on the directory
are never closed, file descriptors are getting used up.

Therefore, it is either an issue with Perl's sysopen() or
some Solaris'ism.

Do you have the ability to try a later version of Perl or
a different OS?