[Top] [All Lists]

Re: [Nmh-workers] whatnow attach usage

2006-07-17 10:38:53
I added those 2 lines to .mh_profile but still doesn't work.
Error message:

  mhbuild: draft shouldn't contain MIME-Version: field

And this is the draft message:

  Fcc: +outbox
  Subject:test attach
  X-MH-Attachment: /Users/phil/Desktop
  X-MH-Attachment: /Users/phil/Desktop/Job-Sites.pdf
  MIME-Version: 1.0
  Content-Type: text/plain; charset="us-ascii"
  Content-ID: <3981.1152989735.1@organtin.local>

You can't MIMEfy a message twice, which is what this has tried to do.
The presence of an attach header in the draft causes it to be MIMEfied,
if I remember correctly, so the draft must *not* be MIMEfied when you
send it.

Did you run it through mhbuild manually or do you have automimeproc set?

I have "automimeproc: 1" set in my .mh_profile.
It looks like the message already gets MIMEfied when (or before) I do
'attach <filename>' and the AGAIN when I 'send'; when I have "automimeproc:
0" it works. Is this (unwanted MIMEfication) a bug?
Speaking about bugs: the first "X-MH-Attachment:" shouldn't be there, right?


It does sound like there should at least be some documentation to the effect
that automimeproc should not be set if the attachment code is being used.
Possibly I should even check for this and force automimeproc to 0.

The "X-MH-Attachment: /Users/phil/Desktop" should not be there, but I can't
tell whether it's a bug or just the result of an attach command from the mail.
Something that I forgot to mention in my earlier note is that you will also
need a like like

        mhshow-suffix-application/pdf: .pdf

in your .mh_profile, but that's probably not the problem here.  Could you please
list all actions that you're taking and include a complete copy of your profile
so that I can figure out what's going on?


Nmh-workers mailing list

<Prev in Thread] Current Thread [Next in Thread>