Date: Fri, 22 Jan 1999 16:17:38 -0800
From: Randall Gellens <randy(_at_)Qualcomm(_dot_)Com>
Cc: wall(_at_)cyrusoft(_dot_)com, Randall Gellens
<randy(_at_)Qualcomm(_dot_)Com>
At 10:53 PM -0500 1/21/99, Lawrence Greenfield wrote:
This contradicts both of our interpretations, since I believe that
actions shouldn't override other actions, and you believe that it's ok
to reject and keep a message.
No, I think it is OK to both reject and redirect (forward) a message.
The message is not kept.
I am strongly opposed to this. It's been discussed before.
I believe that a sender receiving a rejection notice will believe that
their message was never read by a human. I'm not sure I like the idea
of fooling them.
Yes, this bothers me too. But is it any different from a case where
mail is sent to "luser(_at_)foo", which is actually an alias that expands
to "luser(_at_)bar, luser(_at_)gork", and mail sent to "luser(_at_)gork"
bounces?
Yes, it is, in two ways. First, if it's a sendmail alias, the envelope
isn't rewritten. (A Sieve implementation should do that, right?)
Also, the original sender can see a difference between a bounce from
luser(_at_)foo, who he sent mail to, and luser(_at_)gork, who he didn't.
Incidentially, I really think we should dump implicit keep. If this is
not the case, I'd really like to know it now.
> I think multiple fileinto's are a very useful thing---I think users
> will expect it, though I realize that this is hard (impossible?) for
> some systems. I think on those systems, multiple fileinto's should be
> handled the same way #1 is above.
I think this should be a compile error on systems that don't support
it. The question is how to spell it.
This is very hard (or impossible if you imagine an extension of some
tests) to detect at compile time. For instance:
if (size :over 50K) {
fileinto "big";
}
if (size :under 55K) {
fileinto "small";
}
That's my point exactly. We need to distinguish a single file-into
from a multiple file-into. Let's say we spell them "FileInto" and
"CopyInto". Then, if more than one "FileInto" is executed, only one
of them is effective (which one is an open point). If more than one
CopyInto is done, all are effective. If both a CopyInto and a
FileInto are done, both are effective.
I suggest "FileInto" and "FileOnlyInto", or possibly, add an optional
tagged argument to Fileinto, ":only".
--
Tim Showalter <tjs+(_at_)andrew(_dot_)cmu(_dot_)edu>