Re: and application/vnd.* MIME types

1996-09-26 16:17:21
At 10:28 PM +0200 9/26/96, Achim Bohnet wrote:
"Steven W. Eubanks" said:
I seem to have run into a snag trying to configure MHonArc (currently 1.2.2
with upgrade to 1.2.3 pending) to enable it to successfully handle MIME
attachments of the new 'application/vnd.*' content-type definition.  I've

mhonarc only handles wildcard definitions of the form (see,
search 'MIMEFilter'):


Sorry, my mistake in generalizing.  In actuality I've got the following
MIME types:


My current resource file reads:


And my file has been modified to read:

   %CTExt = (
    'application/',         'xls',
    'application/',    'ppt',

    %CTType = (
    'application/',         'MS-Excel file',
    'application/',    'MS-Powerpoint file',

And this results in the "Could not process..." warning for me....
       Could not process part with given Content-Type:
application/; name="idp97.xls" ;
       x-mac-type="584C5335" ; x-mac-creator="5843454C"

As a test, I edited all of the above instances to omit 'vnd.' and modified
my email client (Eudora) to
use 'application/ms-excel' instead;  worked fine.  (Unfortunately MIME
types are harder to standardize than define ;-)   So I assumed the culprit
was the '.' and started looking at the code in which parses
the content-type to see if it was parsing the above syntax correctly.
However if it worked for you without making the mods/patches to, maybe I'm barking-up the wrong tree.

Hope this helps,

[Poor guy.  I get 130 bytes/sec when surfing in NASAs web pages :-)]

Maybe 130 bytes/sec would ;-)



<Prev in Thread] Current Thread [Next in Thread>