msg00000 conflict problem

1997-05-06 16:37:17
Hi. I have been using mhonarc for several months and have read over the
mailing list archives, but this is the first time I've sent anything to
the list.

I use mhonarc on a list that has a traffic of about 100-200 messages per
day; I run with a 30-day expiration time, so there are on average 2000
to 3000 messages in the archive. I run mhonarc -add once every hour,
from an MH folder.

I am very happy with the results, save for one small problem that I can
almost live with, but it's bugging me. About 2/3 of the time when
mhonarc -add runs, it thinks that the message "msg00000" is available,
and tries to re-use it. It's not available, so this ends up causing a
couple of problems; one of which is that my OUTDIR accumulates files
like these:

-rw-rw-r--  1 daemon  daemon  1388 May  1 09:10 h2/
-rw-rw-r--  1 daemon  daemon  1408 Apr 30 14:21 h2/
-rw-rw-r--  1 daemon  daemon  1584 Apr 30 11:55 h2/
-rw-rw-r--  1 daemon  daemon  4259 Apr 28 08:02 h2/
-rw-rw-r--  1 daemon  daemon  4259 Apr 28 08:02 h2/
-rw-rw-r--  1 daemon  daemon  1698 Apr 21 10:04 h2/

And of course there are errors in the topic links. I'm not a terribly
experienced perl programmer, but as I look over the code it appears to
me that the problem is in get_last_msg_num; somehow it is incorrectly
reporting $max to be 0 instead of a much larger number. 

Has anybody else experienced this problem, and is there a known
workaround? I can probably butcher the code so that it never returns a
value of 0 for $max, but that's fixing the symptom and not the problem.

Brian Reid

<Prev in Thread] Current Thread [Next in Thread>