Problem running mhonarc

1998-05-17 22:00:28
I am new to the list, so if this is a worn out topic, I apologize up front.

I recently installed MHonArc 2.2 on my machine (UNIX RedHat Linux 5.0 and
perl 5.004) via the perl script.  Things went swimmingly and
there seems to be no issues with installation.

However, when I actually run mhonarch, the shell simply immediately returns
to a prompt.  There are no error messages, no output and no system
resources are consumed.  I tried running it by passing it a mailbox and by
piping to stdin and both generate the same result (which is no result!).

Running it directly through perl with the debug switch, perl simply steps
through the two unshift statements that comprise the mhonarch file and then
it quits.   It seems as if after it loads the libraries, it doesn't
actually try to run anything.  It just loads and quits.

So I got smart(or so I thought) and thought that maybe there was an issue
with how the libraries loaded, so I took all the libraries and made one big
file, called it newmhonarc and ran it.   This time, it loads up and runs,
but no matter what I pass in regards to options or parameters, mhonarch
just comes back with the "help" screen.  (the output that lists all the
options, etc.).

As  is painfully obvious, my perl skills are utilitarian at best.  I have
had no trouble with any of my other perl stuff, like majordomo, my cgi
stuff, etc.

Does anyone have some leads for me?    Thanks!

Spencer Yost
Owner, ATIS
Plow the Net!

<Prev in Thread] Current Thread [Next in Thread>