Re: help using eval to fix "times not implemented"

1998-05-28 15:38:31

I was involved in that previous thread. Here's the specific code that
worked for me in for v.2.2.0.

line 74:        eval { $StartTime = (times)[0]; };
line 1384:      eval { $EndTime = (times)[0]; };

Ed Venzke

At 06:35 PM 5/28/98 +0530, you wrote:
I saw this in some archives for mhonarc:
I just installed Mhonarc 2.2.0 and am now getting a "times not implemented
at line 74" error. There were no problems under any of the
mhonarc 2.1 versions.  

Running under Perl v. 5.003_07 (Perl for Win32 build 316).  System is Win95
running Mhonarc in a DOS window with a batch file.

I bet you will get the same error with v2.1 if you sepcify the -time

In v2.2, CPU time info is always computed, and -time just tells
MHonArc if it should echo the results.  A fix for systems that
have not implement times() is to wrap the offending statement
in an "eval { };" block.

I've fussed around with eval and am not getting something right as now
mhonarc doesn't do anything at all.  Would someone be kind enough to
either email me the proper surgery for or, less preferably,
point me to 2.1?   

thanks, Paul.
Paul R.D. Lantinga Sr. Network Engineer
Verifone India,  Bangalore an HP company
VirusScan 1.0 - Windows found: Remove it? (Y/N)

Volcano Postmaster / Webmaster
Global Volcanism Program, MRC 129
National Museum of Natural History
Smithsonian Institution
Washington DC 20560

Email:  postmaster(_at_)volcano(_dot_)si(_dot_)edu

<Prev in Thread] Current Thread [Next in Thread>