There has been some community input suggesting that "Return [Path]
address" and "Return Handler" would be better choices.
The Return-path is a header with an address which is the reverse-path.
Reverse-path is better than "Bounce handling address". I prefer
"Return-path Handler" over "Return Handler" as people may be able to
relate to what they see in a message.
Using the RFC2822 field name Return-Path has obvious appeal, but I am
a) it is not in broad use and is restricted to a smaller email geek
community -- maybe that's ok?, and
b) the string really isn't a "path" even tough it might be legal to be --
it's an address, and
c) the non-geek community uses the term 'return address' for mail that
contains the same semantic information, albeit from the postal world.