Re: Question on Errors

1996-04-15 13:22:01
  -rwxrwxrwx   1 daemon   webadmin    1108 Apr 12 17:18 .resource
  drwxrwxrwx   6 daemon   webadmin    8192 Apr 12 17:18 .
  ----------   1 daemon   webadmin       0 Apr 12 17:18 .mhonarc.lck

Delete the existing ".mhonarc.lck" file.  It appears one has been
left behind from an abnormal temrinated mhonarc process.  If a lock
file exists, mhonarc will try for awhile to lock it before it gives
up.  The amount of times it tries can be set via -locktries.

I tried that many times, each time removing the lock file. It gets 
recreated just as before.  Same error message.
What version of Perl are you using?  I believe the key text is
"sh: 14929 Memory fault" which is generated from /bin/sh.

Here's what my Perl reports as version info ...

This is perl, version 4.0
$RCSfile: perl.c,v $$Revision: $$Date: 1993/02/05 19:39:30 $
Patch level: 36

The problem appears to be a memory related.  If a memory error occurs,
there is no way for mhonarc to clean up since it will terminate

Try the command from a shell to see that everything works as expected.
Maybe there is a per process memory limitation taking effect when
invoking a processes via sendmail.

Can anybody experienced with sendmail help?


P.S.  What system are you using?  Just to double check, is the version
of Perl you listed the same perl that is pointed to in the #! line of
the (installed) mhonarc source.  There is a version of Perl 5 that
causes a core dump when when any command-line options are used.
v5.001m and v5.002 do not exhibit this problem.

<Prev in Thread] Current Thread [Next in Thread>