[Top] [All Lists]

[nmh-workers] localhost anomaly

2019-06-18 02:52:38
My apologies for posting here without actually being an NHM "worker".
I hope you folks won't begrudge me too much for doing so, even though
this may turn out to be a "support" type question.

've recently been upgrading an ancinet old FreeBSD 9.1 system to FreeBSD
12.0.  In the process, I am installing all fresh new and updated binaries 
for everything, of course.  In the process, many small things have broken.
This is just one of those.

I installed the nmh-1.7.1 pre-built package on this new FreeBSD 12.0
system, and mostly everything just works, with one small but glaring

When I sent to diddle my /usr/local/etc/nmh/mts.conf file, I elected
to leave things pretty much as they had been on my old system. In
particular, I left the following two settings, which have worked for
me for years, in place:

mts: smtp
servers: localhost

Note that I have the FreeBSD pre-built package called postfix-3.3.4,1
installed, configured, and (arpparently) running well already.  (I am
sending this email through it.)  I also checked to make sure that my
installed and running instance of Postfix is properly accepting the

    telnet 25

It *is* doing so.  I get the expencetd SMTP greeting banner.

Nontheless, for reasons that are beyond me, when I tried to use nmh to
send an outbound email, I consistantly got errors telling me that nmh
had experienced a failure when trying to connect to the SMTP server.

The exact errors are/were as follows:

post: problem initializing server; [BHST] Connection to "localhost" failed: 
Connection refused
send: message not delivered to anyone

I really can't figure this out and would appreciate some help getting to
the bottom of this.

For the time being, I have found that I can simply and easily work around
the problem by using instead: "mts: sendmail/pipe" however whenever I see
something not working that should be working, I usually like to get to the
bottom of it.  I almost always learn something, and usually it is something
that I, in my abundant ignorance, have done horribly wrong.  (So that is
always educational.)

If anybody can explain the errors I saw when using "mts: smtp" together
with "servers: localhost" I sure would appreciate it.


P.S.  The output of the "getent hosts localhost" on this new/fresh FreeBSD
system is currently as follows:

::1               localhost         localhost  localhost.tristatelogic.com

Are the nmh components perhaps trying to connect to my smtp server via IPv6
in preference to IPv4?

If so, how do I disable that behavior? (I am not using IPv6 and I do not have
either any wish nor any real motivation to do so anytime soon.  Please do
not proselytize me about this.  I am already well aware of all the arguments,
both religious and otherwise.)


<Prev in Thread] Current Thread [Next in Thread>