RE: Converting entire directories on Windows NT

2000-06-29 12:57:43

I have just migrated my archive operating from Unix to NT, and encountered the same problem as you guys described. When I typed the perl -e command, it returns *.msg. My perl-win32 is v5.6.0 built 613 from ActiveState. According to their web site, it's the latest. But the problem still not solved. Searching their site, and their FAQ etc, seems have no mension about this at all? Is there any patch, solution (either in perl, or in mhonarc) etc so that it can fix this problem.



You probably have a wildcard expansion problem.

Type this exact command line to the respective 95 and NT MS DOS shells:

   perl -e "print join(' ',@ARGV)" e:\logfiles\*.log

If you see a literal e:\logfiles\*.log (with the asterisk) in the output,
then the wildcard file name is not getting expanded by either the command
processor or the Perl interpreter.  (Or there are no files matching *.log in
that directory.)  On the system I'm working from now (Win 95, ActiveState
Perl 5.004_71) the Perl interpreter does expand the wildcard name into a
list.  I suspect that you are not getting that under NT.

-- SP

> All,
>       I scoured the archive for an answer so I hope this is not a
> duplicate.  I just installed Mhonarc on an NT server with the hopes of
> converting some NTList log files to HTML.  NTList (the
> listserver product
> for NT Mail) stores a given days messages in a file.  For
> example, today is
> LL990411.log.  I want to be able to point Mhonarc at a
> directory and have it
> convert all the log files in the directory.
>       Here is my problem: under Windows 95, I can point mhonarc at the
> directory and use a *.log wildcard.  It successfully finds
> and converts all
> the files for a given list.
> For example,  perl mhonarc e:\logfiles\*.log
> However, the exact same syntax under NT returns "No such file
> or directory."
> I can, however, aim Mhonarc at a specific log file and it
> works properly.
> If I aim at just the logfile directory (perl mhonarc
> e:\logfiles) , the
> response reads "No New Messages."  Because the logfiles can
> contain more
> than one message, the mhpattern resource does not seem to be
> the answer.
> Any ideas would be greatly appreciated.
> Charles Kronbach
> ckronbach(_at_)cerner(_dot_)com

Bosco Tsang, System Analyst
Computing and Communication Services
University Of Guelph, Ontario. Canada, N1G 2W1