Thanks for providing us with a different perspective of RFC 5321.
At 23:10 06-11-2008, Ivar Lumi wrote:
What about something like:
it MUST insert trace time-stamp-line("Received:" header) .... or vice versa.
("time stamp" or "Received")
The "or" in current version is not the best, both terms are noting
same stuff, while "or" refers to choice one or the another.
Reading Section 4.4 again, I see that the ("time stamp" or
"Received") might seem confusing to some people because of the
"or". It is commonly known as the "Received" header. I wouldn't
mind the redundancy if it makes the text clearer to
implementors. I'm leaving in "trace" as the section is about trace
When an SMTP server receives a message for delivery or further
processing, it MUST insert trace (also referred to interchangeably as "time
stamp" or "Received") information at the beginning of the message
content, as discussed in Section 22.214.171.124.
Do you find the above clear enough?